Dashboard and Outbound Call Authentication Issues

Incident Report for Phone System Status

Resolved

After a period of successful monitoring this incident is marked as resolved.
Posted Jul 11, 2025 - 15:56 BST

Monitoring

We have seen all services return to normal and are actively monitoring the issue. This will be marked as resolved after a period of successful monitoring.
Posted Jul 11, 2025 - 12:47 BST

Identified

We have identified the issue and working on a fix. Next update within 20 minutes.
Posted Jul 11, 2025 - 12:23 BST

Investigating

Our team are investigating reports of issues with outbound calls and navigating dashboards. We will provide a further update within 30 minutes.
Posted Jul 11, 2025 - 12:14 BST
This incident affected: VoIP Platform, Calls, and Pulse HD Mobile/Desktop App.