Issues with phones connecting

Incident Report for Phone System Status

Resolved

This is confirmed as resolved.
Posted Jul 10, 2025 - 09:46 BST

Update

A fix has been implemented and we are monitoring the situation.
Posted Jul 09, 2025 - 14:27 BST

Update

We are seeing degraded performance in some areas and working on the fix as we speak.
Posted Jul 09, 2025 - 13:59 BST

Monitoring

Normal service has resumed again and our team continue to closely monitor the situation.
Posted Jul 09, 2025 - 13:27 BST

Identified

We're investigating further reports of similar issues and will provide a further update within 30 minutes
Posted Jul 09, 2025 - 12:52 BST

Monitoring

Service has been restored in most areas and continues to improve in some niche cases. Our Team are still monitoring the incident and will provide mark this as resolved after a successful period.
Posted Jul 09, 2025 - 11:57 BST

Identified

The affected traffic is being rerouted and we're beginning to see performance in those areas improve. We are continuing to monitor and will provide a further update in the next 30 minutes.
Posted Jul 09, 2025 - 11:41 BST

Update

We are continuing to investigate this issue.
Posted Jul 09, 2025 - 11:41 BST

Investigating

We are investigating reports of degraded performance across various elements of our platform, including calls, softphone apps and load speeds with our online dashboards.
Posted Jul 09, 2025 - 11:15 BST
This incident affected: VoIP Platform and Calls.